My Photo

Microsoft Dynamics 365

Official Blog for Microsoft Dynamics Functional and Technical Solutions....
Browsing Category " error in mscrm "

Unable to Connect Plugin Registration tool with MS CRM v9 / D365 SDK

On
ISSUES:

Not able to login Plugin registration tool (Keep popping up for Credentials)

Resolution:

1. Update latest SDK from the Download tools from NuGet or Quick start Plugin Registration Tool V9.0.0.7

For downloading the latest PRT from VS Nuget packages - this link might be useful

2. Modify using TSL to 1.2 through Fiddler .

Step 1 Open Fiddler and navigate to Tools - Options - HTTPS Tab


Step 2 Under HTTPS tab click on to Protocols link - a Popup will come change the TLS vesion from 1.0 / 1.1 to tls 1.2.  i.e. " <client>;ssl3;tls1.2 " and press on ok


Now you will be able to connect to your CRM v9 Organisation with PRT

Happy CRMing 😊

SOURCE : mscrm.com

Could not load file or assembly 'Microsoft.Bot.Connector, Version=3.12.2.4, Culture=neutral, PublicKeyToken=##' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Could not load file or assembly 'Microsoft.Bot.Connector, Version=3.12.2.4, Culture=neutral, PublicKeyToken=##' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Error 


Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.IO.FileLoadException: Could not load file or assembly 'Microsoft.Bot.Connector, Version=3.12.2.4, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)



Reason

 Microsoft.Bot.Builder library got update to Version=3.12.2.4

Resolution

Update the Microsoft.Bot.Builder library to latest version

Right Click on your Project and Click on manage NuGet Packages


Search for Microsoft.Bot.Connector and click on update  


Then press on accept




Hope It helps

Happy Coding 😊

SOURCE : mscrm.com

How to disable Send Report to Microsoft error popup in Microsoft dynamics CRM

Microsoft dynamic CRM throw an error constantly to send an summary of problem to Microsoft, that sometime get irritating mainly while development and testing. we can disable send report to Microsoft popup throw CRM.



1. Navigate to Microsoft Dynamics CRM > Settings > Administration > Privacy Preferences On the Privacy Preferences Tab


2. select the option “ Specify the Web Application Error Notification preferences on behalf of users” Select the “Never send error report to Microsoft”


Some time this doesnt solve the problem in IE10, IE11.

Click on ‘Compatibility View Settings’ on IE and add the CRM url to the compatibility view settings


Hope this was helpfull . thanks

Follow us on facebook : https://www.facebook.com/microsoftdynamicsindia/

ERROR : the plugin execution failed because no sandbox hosts are currently available please check that you have a sandbox server configrated ( System.ServiceModel.EndpointNotFoundException) In MSCRM 2011 , MSCRM 2013 , MSCRM 2015 , MS CRM


Hi , I got an error will executing a PLUGIN in ISOLATION mode ,

ERROR :   The plug-in execution failed because no Sandbox Hosts are currently available. Please check that you have a Sandbox server configured and that it is running. System.ServiceModel.EndpointNotFoundException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #357E9BEE

There are several cause for this error but most commom is : CRM Sandbox service is not running

Fields that are not valid were specified for the entity - Importing Solution Error mscrm 2011 , mscrm 2013 , mscrm 2015

Hey , I was importing a solution today from an other Organization and got a Error new to me :  Fields that are not valid were specified for the entity , as there was no description i was little confused , but after few R&D came up with perfect resolution of the error .

Reason 

  • Organization "A" conatined attribute 'new_mscrm' that was of type "single line" ,Later  We changed that the field  to be an currency Type.
  • But in Organization "B" was containg same field 'new_mscrm' of type "Single line".
  • When we tried to import back the new solution to test environment we got this Import failure